日本語でプログラミング!「なでしこ」条件分岐編 ♯3

「ランドセル」「お辞儀」で連想できるあの あるある って、実際はなかなか ないない なんじゃないかって思いました。

なんか早口言葉みたい…?

今回は、条件分岐をやってみます。
個人的には、「プログラミングと言えば」な気がします。

式で条件分岐

ではまず、合言葉を入力させて、合っていれば特定のメッセージを表示するプログラムを書いてみましょう。

「落ち着く言葉なんかあるの?」と尋ねる。
合言葉はそれ。
もし、合言葉が「ふわふわ」ならば
 「ありがとう」と言う。
違えば
 「何それ?」と言う。
ここまで。
終了。

このソースの解説です。
1行目の『尋ねる』は、かぎかっこ内の言葉を表示してからユーザの文字入力を待つ動作をします。
ユーザが文字入力をして「決定」ボタンを押すと、2行目の『それ』に入力した値が入るので、その内容を変数『合言葉』に代入しています。
3行目が今回の肝となる、条件分岐です。この場合は、変数『合言葉』の値が「ふわふわ」のときに4行目のメッセージ「ありがとう」を表示する処理を実行します。また、「ふわふわ」以外の文字が入力されたときには、6行目の処理を行います。
7行目の『ここまで』は、条件式の終了を指します。

続いて、生年月日を入力したら現在の年齢によってメッセージを表示するプログラムを書いてみます。

「生まれた年の西暦」を尋ねる。
誕生年はそれ。
「生まれた月」を尋ねる。
誕生月はそれ。
「生まれた日」を尋ねる。
誕生日はそれ。

生年月日は「{誕生年}/{誕生月}/{誕生日}」。

年齢は生年月日と今日の日数差/365の整数部分。

もし、年齢が16以下ならば
 「高校生以下です。」と言う。
違えばもし、年齢が19以下ならば
 「未成年です。」と言う。
違えば
 「成人です。」と言う。
ここまで。
終了。

このプログラムの条件式では、年齢が「16以下」「17~19」「20以上」の3つのパターンで分岐しています。
このように書くことで、複数の条件のいずれかに当てはまる場合の条件分岐を書くことができます。
ちなみに、7行目の『生年月日』を入れている行についての解説は、前回の「四則演算・変数編 ♯2」でやっていますので、わからない方はご参照ください。

値で条件分岐

また大小比較でなく、特定の値かどうかでの分岐であれば次のような書き方も出来ます。

・・・

年齢で条件分岐
 12ならば
  「小学校卒業おめでとう。」と表示。
 15ならば
  「中学校卒業おめでとう。」と表示。
 18ならば
  「高校卒業おめでとう。」と表示。
ここまで。
終了。

条件分岐を使うと色んなことができるようになるので、ぜひマスターしてみてくださいね。